Author - StudySection Post Views - 60 views
Laravel Imagemagick

Imagemagick FailedToExecute Laravel

ERROR:

===========================================
FailedToExecuteCommand `"gswin64c.exe" -q -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 "-sDEVICE=pngalpha" -dTextAlphaBits=4 -dGraphicsAlphaBits=4 "-r72x72" "-sOutputFile=C:/Users/HP/AppData/Local/Temp/magick-kacJxztXpYJAbO2fgrwYcsaOsZ88_uZ%d" "-fC:/Users/HP/AppData/Local/Temp/magick-G2CnhfadRHdRKc1hqsddfsrIpJpNxEwgsi" "-fC:/Users/HP/AppData/Local/Temp/magick-BvBOpDHNDJEIededWE7y6I1bKJYiF"' (The system cannot find the file specified.
===========================================

For this specific error, You need to install Ghostscript on your Windows system. I got this error on my Windows 10 64 bit machine. This error occurs when you haven’t installed Ghostscript on your system or you have installed a different Ghostscript version that is not compatible with Imagemagick.

Ghostscript helps you to print your document in JPEG and PNG format. We need to follow three simple steps in order to install Ghostscript.

Step 1: Open the following link on any browser and download the specific version of Ghostscript.
https://www.ghostscript.com/download/gsdnld.html

You can choose either the 64-bit version or the 32-bit version depending upon your system. I downloaded the 64-bit version as my Windows 10 is compatible with it. The current version as of writing this post is “Ghostscript 9.54.0 for Windows (64 bit)”.

Step 2: Use the default directories for installation and hit the next button for the installation. Now hit the window button and search Ghostscript. Open it and you will find the GS> prompt. It means you have successfully installed Ghostscript.

If the error still persists then you need to downgrade the Ghostscript installation version. For this please uninstall the old Ghostscript version which was installed previously and reinstall it from the following link, This link provides you the specific Ghostscript version of 9.22.

https://www.npackd.org/p/com.ghostscript.Ghostscript/9.22

By following these steps, the error should be resolved.

If you have skills in PHP programming and you want to enhance your career in this field, a PHP certification from StudySection can help you reach your desired goals. Both beginner level and expert level PHP Certification Exams are offered by StudySection along with other programming certification exams.

Leave a Reply

Your email address will not be published.